<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<meta http-equiv="Content-Security-Policy" content="block-all-mixed-content">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-9356934496955375" crossorigin="anonymous"></script>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<script data-cfasync="false" data-pagespeed-no-defer>
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
</script>


<title>Who Died in the White Lotus Season 2 Finale? Answered</title>
<meta name="description" content="If you’re wondering who died in the White Lotus season 2 finale, don’t worry, we got you covered. The answer is one click away." />
<link rel="canonical" href="https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Who Died in the White Lotus Season 2 Finale? Answered" />
<meta property="og:description" content="If you’re wondering who died in the White Lotus season 2 finale, don’t worry, we got you covered. The answer is one click away." />
<meta property="og:url" content="https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/" />
<meta property="og:site_name" content="Twinfinite" />
<meta property="article:publisher" content="https://www.facebook.com/2winfinite" />
<meta property="article:published_time" content="2022-12-12T19:40:57+00:00" />
<meta property="article:modified_time" content="2022-12-12T19:41:04+00:00" />
<meta property="og:image" content="https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="676" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Rafa Boladeras" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="2 minutes" />

<link rel='dns-prefetch' href='//infinite-scroll-js-bundle.gamurs.workers.dev' />
<link rel="alternate" type="application/rss+xml" title="Twinfinite &raquo; Feed" href="https://twinfinite.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="Twinfinite &raquo; Comments Feed" href="https://twinfinite.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Twinfinite &raquo; Who Died in the White Lotus Season 2 Finale? Answered Comments Feed" href="https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/feed/" />
<link rel="alternate" type="application/rss+xml" title="Twinfinite &raquo; Stories Feed" href="https://twinfinite.net/web-stories/feed/"><link rel='stylesheet' id='all-css-0' href='https://twinfinite.net/_static/??-eJx1UFlOAzEMvRCpKRKD+ECcJeNYU4OzKHZU5vZ4WnVUpPLp5a1wboELykikgKqQWA1mqfgdhOce+wpqq9Ahczn4wxM4AmsxKgZNxsLFQdVIW+2mYRl+makv4UKiMA+WdOVwpUQ/O8uu+6WQKXEkobzR3g9N4ko9CC0R1z8m/oX77X5+6DyPcDOvFDuegCSqMbZOtxa2OrqvjVJoVT3ctZdLFn3sZcOgMyljsJPr73+f+eM4vT2/vkzvx+kXEY2NAQ==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='hurrytimer-css' href='https://twinfinite.net/wp-content/uploads/hurrytimer/css/d8711c7f79d91e0b.css' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://twinfinite.net/_static/??-eJyVjdEKgkAQRX+oddpIo4foW5b1alPOas7I0t9n0kMQhL1ezjmX8uBinwzJyC4QKMWO481JaEnt0aGIqhv6gTnLnBpObFhp0AzQCIX9FW9mxoUM7QVL4nNYdyqoObj7hJGhX4pMbuimlpPSFTaEWfS+qBbzPbycs5x8ddiWu+q4L5/NNnYS' type='text/css' media='all' />
<style id='mvp-custom-style-inline-css'>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</style>
<link rel="https://api.w.org/" href="https://twinfinite.net/wp-json/" /><link rel="alternate" type="application/json" href="https://twinfinite.net/wp-json/wp/v2/posts/878751" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://twinfinite.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://twinfinite.net/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.1.1" />
<link rel='shortlink' href='https://twinfinite.net/?p=878751' />
<link rel="alternate" type="application/json+oembed" href="https://twinfinite.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftwinfinite.net%2F2022%2F12%2Fwho-died-the-white-lotus-season-finale%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://twinfinite.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftwinfinite.net%2F2022%2F12%2Fwho-died-the-white-lotus-season-finale%2F&#038;format=xml" />
<script type="text/javascript">
          (function() {
            /** CONFIGURATION START **/
            var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
            _sf_async_config.uid = 66987;
            _sf_async_config.domain = 'twinfinite.net'; //CHANGE THIS TO THE ROOT DOMAIN
            _sf_async_config.flickerControl = false;
            _sf_async_config.useCanonical = true;
            _sf_async_config.useCanonicalDomain = true;
                                    _sf_async_config.sections = 'Guides'; // CHANGE THIS TO YOUR SECTION NAME(s)
            _sf_async_config.authors = 'Rafa Boladeras'; // CHANGE THIS TO YOUR AUTHOR NAME(s)
                        /** CONFIGURATION END **/
            function loadChartbeat() {
                var e = document.createElement('script');
                var n = document.getElementsByTagName('script')[0];
                e.type = 'text/javascript';
                e.async = true;
                e.src = '//static.chartbeat.com/js/chartbeat.js';
                n.parentNode.insertBefore(e, n);
            }
            loadChartbeat();
          })();
        </script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<script type="text/javascript" async>
          ;(function(p,l,o,w,i,n,g){if(!p[i]){p.GlobalSnowplowNamespace=p.GlobalSnowplowNamespace||[]; p.GlobalSnowplowNamespace.push(i);p[i]=function(){(p[i].q=p[i].q||[]).push(arguments) };p[i].q=p[i].q||[];n=l.createElement(o);g=l.getElementsByTagName(o)[0];n.async=1; n.src=w;g.parentNode.insertBefore(n,g)}}(window,document,"script","https://twinfinite.net/plow.lite.js","snowplow"));
        </script>
<script>
          window.snowplow('newTracker', 'sp1', 'https://spc.twinfinite.net/', { 
            appId: 'twinfinite-web',
          });
          snowplow('enableActivityTracking', { 
            minimumVisitLength: 30,
            heartbeatDelay: 10,
          });
          window.snowplow('trackPageView');
          window.top.addEventListener('primisPlayerInit', function (e) {
            if (e.detail.playerApiId == 'primisPlayer') {
              var player = e.detail;
              player.addEventListener('adStarted', function (val) {
                window.snowplow('trackSelfDescribingEvent', {
                  event: {
                    schema: 'iglu:group.gamurs/primis_ad_impression/jsonschema/1-0-0',
                    data: {
                      impressionValue: val.impValue,
                      servingFee: val.servingFee,
                    }
                  }
                });
              });
            }
          });
        </script>
<script>
          (function() {
            var processCWV = function(obj) {
              window.snowplow('trackSelfDescribingEvent', {
                event: {
                  schema: 'iglu:group.gamurs/core_web_vitals/jsonschema/1-0-0',
                  data: {
                    name: obj.name,
                    value: obj.value,
                    delta: obj.delta,
                  },
                },
              });
            }
            var script = document.createElement('script');
            script.src = 'https://unpkg.com/web-vitals/dist/web-vitals.iife.js';
            script.onload = function() {
              webVitals.getCLS(processCWV);
              webVitals.getFID(processCWV);
              webVitals.getLCP(processCWV);
            }
            document.head.appendChild(script);
          }())
        </script>
<style>img#wpstats{display:none}</style>


<script data-cfasync="false" data-pagespeed-no-defer>
	var dataLayer_content = {"visitorDoNotTrack":0,"siteID":0,"siteName":"","pageTitle":"Who Died in the White Lotus Season 2 Finale? Answered","pagePostType":"post","pagePostType2":"single-post","pageCategory":["guides"],"pageAttributes":["guide","guides","hbo","the-white-lotus","tv-series","tv-show"],"pagePostAuthor":"Rafa Boladeras","pagePostDate":"December 12, 2022","pagePostDateYear":"2022","pagePostDateMonth":"12","pagePostDateDay":"12","pagePostDateDayName":"Monday","pagePostDateHour":"14","pagePostDateMinute":"40","pagePostDateIso":"2022-12-12T14:40:57-05:00","pagePostDateUnix":1670856057,"pagePostTerms":{"category":["Guides"],"post_tag":["Guide","Guides","HBO","the white lotus","TV series","TV Show"],"internal-label":["Entertainment (Q3)"],"article_type":["SEO"],"author":["RafaBoladeras"]},"browserName":"Googlebot","browserVersion":"2.1","browserEngineName":"","browserEngineVersion":"","osName":"","osVersion":"","deviceType":"bot","deviceManufacturer":"","deviceModel":"","postID":878751,"geoCloudflareCountryCode":"US"};
	dataLayer.push( dataLayer_content );
</script>
<script data-cfasync="false">
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NWJQJXJ');
</script>

<link rel="preload" as="image" href="https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg?resize=500%2C250" /><link rel="icon" href="https://twinfinite.net/wp-content/uploads/2016/04/cropped-logo-2.png?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://twinfinite.net/wp-content/uploads/2016/04/cropped-logo-2.png?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://twinfinite.net/wp-content/uploads/2016/04/cropped-logo-2.png?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://twinfinite.net/wp-content/uploads/2016/04/cropped-logo-2.png?fit=270%2C270" />
<style type="text/css" id="wp-custom-css">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</style>
<link rel="pingback" href="https://twinfinite.net/xmlrpc.php" />
<meta property="og:image" content="https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg?resize=1000%2C600" />
<meta property="og:type" content="article" />
<meta property="og:description" content="Who were the dead bodies in the season 2 finale of The White Lotus, explained." />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@Twinfinite">
<meta name="twitter:url" content="https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/">
<meta name="twitter:title" content="Who Died in the White Lotus Season 2 Finale? Answered">
<meta name="twitter:description" content="Who were the dead bodies in the season 2 finale of The White Lotus, explained.">
<meta name="twitter:image" content="https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg?resize=1000%2C600" />
<meta name="yandex-verification" content="54578aa5c9a57741" />
<meta name="msvalidate.01" content="9CAD458F50105839EF863B442BD3F78F" />
<meta name="msvalidate.01" content="125BB20736DF1A96C47068D53CA24035" />

<link rel="preload" href="https://twinfinite.net/wp-content/themes/click-mag-twinfinite/js/jquery.min.js" as="script">
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-25895090-4"></script>
<script>window.dataLayer = window.dataLayer || []; function gtag(){dataLayer.push(arguments);} 
	    gtag('js', new Date());
			
	    gtag('set', 'dimension2',  'Rafa Boladeras');
        gtag('set', 'dimension3',  'Guide'); 
	    gtag('set', 'dimension5',  'Guides'); 
		gtag('set', 'dimension6',  'Dec 2022'); 
		gtag('set', 'dimension7',  'Entertainment (Q3)'); 

	    	    gtag('config', 'UA-25895090-4');
		

window.mainPostID = 878751;
window.mainPostIsSingle = true;
window.mainIsGuide = true;	
window.mainIsQuiz = false;
window.homePage = false;
window.infiniteCat = false;
window.infiniteCatID = 0;
window.publishedTimeFrame = 'Dec 2022'	
	
</script>
<script>
function getCookie(e) {
    for (var n = e + "=", t = decodeURIComponent(document.cookie).split(";"), o = 0; o < t.length; o++) {
        for (var r = t[o];
            " " == r.charAt(0);) r = r.substring(1);
        if (0 == r.indexOf(n)) return r.substring(n.length, r.length)
    }
    return ""
}
if (getCookie('sweetDreams') == "1") {
    document.write('<style class="nightTag">.infinite-post,.mvp-content-side-out{background-color:#000 !important}#mvp-content-main strong{color:#FFFFFF !important; font-weight:bold !important;}.quiz-question-answer-controls{font-weight:600;}.card{background-color:rgba(26,26,27,.8)!important}#mvp-site,.card .sideBarHeader,#mvp-post-bot-wrap,#mvp-side-wrap{color:#d7dadc!important; background-color:#000000;}.pagination a{color:#FFF!important;}#mvp-main-content-wrap{border:hidden!important}.mvp-fly-top-out{background-color:#000!important}#mvp-main-wrap a:not(.FeatLink),.publisher-nav-color,.sideBarHeader{color:#4fbcff!important}#mvp-content-main,.kg-item-desc,.mvp-wide-widget-text a,.pop2,a.publisher-nav-color,blockquote,h1,h2,h3,h4,i,li,p,span,strong,ul,#mvp-fly-menu-wrap a,.card  .sideBarHeader,a.FeatLink{color:#d7dadc!important}span.mvp-story-share-but{background:#223fbd!important} .quiz-section,.quiz-question-answer,#mvp-feat-home-wrap,#mvp-home-body,#mvp-post-content,#mvp-post-content-mid,.mvp-arch-head,.mvp-main-blog-text,h1.mvp-arch-head,header,mvp-main-boxed-wrap,section,#mvp-fly-menu-wrap,#mvp-post-bot-wrap,.reviewBox{background-color:#000000 !important;} #mvp-head-wrap,#mvp-nav-wrap,.mvp-main-nav-cont,#mvp-main-wrap,#mvp-nav-right{background-color:rgba(26, 26, 27, 0.8) !important;}</style>');
}
</script>
<style>
	#sticky-bottom,
	#sticky-top {
		background: rgba(255, 255, 255, 0.9);
		overflow: hidden;
		text-align: center;
		transition: min-height 0.5s;
		width: 100%;
		z-index: 99999;
	}
	#sticky-top {
		display: block;
		height: 50px;
		position: sticky;
		top: 0;
	}
	#sticky-bottom {
		bottom: 0;
		display: block;
		height: 50px;
		position: fixed;
	}
	#skin,
	#proper-ad-twinfinite_billboard iframe[width="1920"][height="1080"] {
		position: fixed !important;
		top: 0;
		right: 0;
		bottom: 0;
		left: 0;
		min-width: 1920px !important;
		text-align: center;
	}
	.proper-ad-unit:not(#skin):not(.sticky-units) {
		display: flex;
		flex-direction: column;
		justify-content: space-between;
		margin-bottom: 20px;
		min-height: 320px;
	}
	.top-billboard {
		display: none !important;
	}
	.side-sticky {
		position: sticky;
		top: 100px;
	}
	div.primis-player {
		display: flex;
		margin: 20px auto;
		padding-top: 80%;
		position: relative;
	}
	div.primis-player.home {
		margin: 0;
		padding-top: 73.196581%;
		width: 90%;
	}
	div.primis-player > div {
		bottom: 0;
		left: 0;
		position: absolute;
		right: 0;
		top: 0;
	}
	#mvp-content-main .proper-ad-unit {
		display: block !important;
		min-height: 320px !important;
		text-align: center;
	}
	#mvp-content-main .proper-ad-unit:before {
		border-bottom: 1px solid #dfdfdf;
		color: #949494;
		content: "Content Continues After Ad";
		font-family: 'Lato', sans-serif;
		font-size: 0.65rem;
		padding: 0 2rem 0.25rem;
		text-transform: uppercase;
	}
	#mvp-content-main .proper-ad-unit > div:first-child {
		margin-top: 0.5rem !important;
		position: -webkit-sticky !important;
		position: sticky !important;
		top: 55px;
	}
	@media (min-width: 37.5em) {
		.top-billboard {
			background: #fff;
			display: flex !important;
			margin-bottom: 0 !important;
		}
		#sticky-bottom,
		#sticky-top {
			display: none;
		}
		.proper-ad-unit:not(#skin):not(.sticky-units) {
			min-height: 290px;
		}
		#mvp-content-main > .proper-ad-unit {
			min-height: 320px !important;
		}
		#mvp-content-main .proper-ad-unit > div:first-child {
			top: 10px;
		}
		div.primis-player {
			padding-top: 70.6410256%;
			width: 100%;
		}
		div.primis-player.home {
			width: 100%;
		}
	}
	@media (min-width:659px)  {
		#mvp-main-content-wrap{
			height: 280px !important;
		}
	}
	@media (max-width:658px)  {
		#mvp-main-content-wrap{
			height: 0 !important;
		}
	}
	@media (max-width: 1920px) {
		#skin #twinfinite_skin {
			height: 1080px;
			max-width: 1920px !important;
			width: 1920px;
		}
		#skin #proper-ad-twinfinite_skin,
		#skin #twinfinite_skin,
		#proper-ad-twinfinite_billboard iframe[width="1920"][height="1080"] {
			margin-left: calc((100% - 1920px)/2) !important;
		}
	}
	/* MV CSS */
	@media only screen and (min-width: 425px) {
		body.mediavine-video__has-sticky #anuUDQLF {
			bottom: 330px !important;
		}
	}
	@media only screen and (max-width: 359px) {
		#mvp-post-content .mvp-post-content-out.relative {
			padding-left: 0px !important;
			padding-right: 0px !important;
		}
		#mvp-post-content-mid {
			width: 100% !important;
			padding-left: 10px !important;
			padding-right: 10px !important;
			box-sizing: border-box !important;
		}
		body.adhesion #anuUDQLF {
			bottom: 120px !important;
		}
	}
	#sticky-top, #sticky-bottom {
		position: static !important;
	}
	/* End MV CSS */
</style>
<script defer async src="https://embed.twitch.tv/embed/v1.js" type="text/javascript"></script>

<script>
var _comscore = _comscore || [];
_comscore.push({ c1: "2", c2: "36750692" });
(function() {
	var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
	s.src = "https://sb.scorecardresearch.com/cs/36750692/beacon.js";
	el.parentNode.insertBefore(s, el);
})();
</script>
<noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=36750692&amp;cv=3.6.0&amp;cj=1">
</noscript>

<script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://terrifictooth.com/v2pvgG7N_kYhscywJkDrSO4LFqk21d2u24v1psmy3Eo28pM9sRU0I5Yc",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){function t(){(t.q=t.q||[]).push(arguments)}t.v=1,o[n]=o[n]||t})(window,String.fromCharCode(97,100,109,105,114,97,108));!(function(o,t,n,c){function e(n){(function(){try{return(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]>0}catch(o){}return!1})()&&(n=o[t].pubads())&&n.setTargeting("admiral-engaged","true")}(c=o[t]=o[t]||{}).cmd=c.cmd||[],typeof c.pubads===n?e():typeof c.cmd.unshift===n?c.cmd.unshift(e):c.cmd.push(e)})(window,"googletag","function");;;!(function(t,n,i,e,o){function a(){for(var t=[],i=0;i<arguments.length;i++)t.push(arguments[i]);if(!t.length)return o;"ping"===t[0]?t[2]({gdprAppliesGlobally:!!n.__cmpGdprAppliesGlobally,cmpLoaded:!1,cmpStatus:"stub"}):t.length>0&&o.push(t)}function c(t){if(t&&t.data&&t.source){var e,o=t.source,a="string"==typeof t.data&&t.data.indexOf("__tcfapiCall")>=0;(e=a?((function(t){try{return JSON.parse(t)}catch(n){}})(t.data)||{}).__tcfapiCall:(t.data||{}).__tcfapiCall)&&n[i](e.command,e.version,(function(t,n){var i={__tcfapiReturn:{returnValue:t,success:n,callId:e.callId}};o&&o.postMessage(a?JSON.stringify(i):i,"*")}),e.parameter)}}!(function f(){if(!window.frames[e]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=e,n.appendChild(i)}else setTimeout(f,5)}})(),o=[],a.v=1,"function"!=typeof n[i]&&(n[i]=n[i]||a,n.addEventListener?n.addEventListener("message",c,!1):n.attachEvent&&n.attachEvent("onmessage",c))})(document,window,"__tcfapi","__tcfapiLocator");;!(function(n,t,i,u,e,o,r){function a(n){if(n){var u=(n.data||{}).__uspapiCall;u&&t[i](u.command,u.version,(function(t,i){n.source.postMessage({__uspapiReturn:{returnValue:t,success:i,callId:u.callId}},"*")}))}}!(function f(){if(!window.frames[u]){var t=n.body;if(t){var i=n.createElement("iframe");i.style.display="none",i.name=u,t.appendChild(i)}else setTimeout(f,5)}})();var s={getUSPData:function(n,t){return n!==1?t&&t(null,!1):t&&t({version:null,uspString:null},!1)}};function c(n,t,i){return s[n](t,i)}c.v=1,"function"!=typeof t[i]&&(t[i]=t[i]||c,t.addEventListener?t.addEventListener("message",a,!1):t.attachEvent&&t.attachEvent("onmessage",a)),o=n.createElement(e),r=n.getElementsByTagName(e)[0],o.src="https://terrifictooth.com/v2usyGd7twEVfP-42Jf6FSghSYFqBlxG3R-4jCw5yLEZiIW8Y_bcTvrhlQxXa_fMayRaniYbj",r.parentNode.insertBefore(o,r)})(document,window,"__uspapi","__uspapiLocator","script");</script>
<script src="https://btloader.com/tag?o=5645585240555520&upapi=true" async></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
	window.googletag = window.googletag || {cmd: []};
	googletag.cmd.push(function() {
    googletag.defineSlot('/143457427/twinfinite_pskin', [1, 1], 'div-gpt-ad-1663206141364-0').addService(googletag.pubads());
		googletag.pubads().enableSingleRequest();

						googletag.pubads().setTargeting('post_categories', ["guides"]);
		googletag.pubads().setTargeting('post_slug', ['who-died-the-white-lotus-season-finale']);
		googletag.pubads().setTargeting('post_tags', ["guide","guides","hbo","the-white-lotus","tv-series","tv-show"]);
		googletag.pubads().setTargeting('post_title', ['Who Died in the White Lotus Season 2 Finale? Answered']);
				
		googletag.enableServices();
	});
</script>
</head>
<body class="post-template-default single single-post postid-878751 single-format-standard wp-embed-responsive">

<noscript><iframe  src="https://www.googletagmanager.com/ns.html?id=GTM-P8P9HTB"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="mvp-fly-wrap">
<div id="mvp-fly-menu-top" class="left relative">
<div class="mvp-fly-top-out left relative">
<div class="mvp-fly-top-in">
<div id="mvp-fly-logo" class="left relative">
<a href="https://twinfinite.net/"><img src="https://twinfinite.net/wp-content/uploads/2018/08/Twinfinite-Logo-New.png" alt="Twinfinite" data-rjs="2" /></a>
</div>
</div>
<div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</div>
</div>
<div id="mvp-fly-menu-wrap">
<nav class="mvp-fly-nav-menu left relative">
<div class="menu-menu-container"><ul id="menu-menu" class="menu"><li id="menu-item-92" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92"><a href="https://twinfinite.net/category/features/">Features</a></li>
<li id="menu-item-381971" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-381971"><a href="https://twinfinite.net/category/guides/">Guides</a></li>
<li id="menu-item-93" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-93"><a href="https://twinfinite.net/category/news/">News</a></li>
<li id="menu-item-97" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://twinfinite.net/category/reviews/">Reviews</a></li>
<li id="menu-item-106" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-106"><a href="https://twinfinite.net/category/xbox-one/">Xbox</a></li>
<li id="menu-item-95" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-95"><a href="https://twinfinite.net/category/pc/">PC</a></li>
<li id="menu-item-96" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96"><a href="https://twinfinite.net/category/ps4/">PlayStation</a></li>
<li id="menu-item-250317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-250317"><a href="https://twinfinite.net/category/switch/">Nintendo</a></li>
<li id="menu-item-181803" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181803"><a href="https://twinfinite.net/category/entertainment/">Entertainment</a></li>
<li id="menu-item-418729" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-418729"><a href="https://twinfinite.net/category/quiz/">Quizzes</a></li>
<li id="menu-item-789520" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-789520"><a href="#">About Us &#038; Policies</a>
<ul class="sub-menu">
<li id="menu-item-803504" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-803504"><a href="https://twinfinite.net/about-us/">About Us &#038; Contact</a></li>
<li id="menu-item-803503" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-803503"><a href="https://twinfinite.net/contact-us/">Contact Us</a></li>
<li id="menu-item-789521" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-789521"><a href="https://twinfinite.net/fact-checking-policy/">Fact-checking Policy</a></li>
<li id="menu-item-789522" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-789522"><a href="https://twinfinite.net/ownership-policy/">Ownership Policy</a></li>
<li id="menu-item-789523" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-789523"><a href="https://twinfinite.net/corrections-policy/">Corrections Policy</a></li>
<li id="menu-item-789524" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-789524"><a href="https://twinfinite.net/ethics-policy/">Ethics Policy</a></li>
</ul>
</li>
</ul></div> </nav>
</div>
<div id="mvp-fly-soc-wrap">
<span class="mvp-fly-soc-head">Connect with us</span>
<ul class="mvp-fly-soc-list left relative">
<li><a href="https://www.facebook.com/2winfinite/" target="_blank" class="fa fa-facebook-official fa-2"></a></li>
<li><a href="https://twitter.com/Twinfinite" target="_blank" class="fa fa-twitter fa-2"></a></li>
</ul>
</div>
</div>
<div id="mvp-site" class="left relative">
<header id="mvp-head-wrap" class="left relative">
<div id="mvp-head-top" class="left relative">
<div id="mvp-search-wrap">
<div id="mvp-search-box">
<form method="get" id="searchform" action="https://twinfinite.net/">
<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
<input type="hidden" id="searchsubmit" value="Search" />
</form> </div>
<div class="mvp-search-but-wrap mvp-search-click">
<span></span>
<span></span>
</div>
</div>
</div>
<div id="mvp-nav-wrap" class="left relative">
<div class="mvp-main-boxed-wrap">
<div class="mvp-main-out relative">
<div class="mvp-main-in">
<div class="mvp-main-nav-cont left relative">
<div class="mvp-nav-left-out">
<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
<span></span>
<span></span>
<span></span>
<span></span>
 </div>
<div id="mvp-logo-nav" class="left relative">
<a itemprop="url" href="https://twinfinite.net/"><img class="skip-lazy" src="https://twinfinite.net/wp-content/uploads/2018/08/Twinfinite-Logo-New.png" alt="Twinfinite" data-rjs="2" /></a>
<h2 class="mvp-logo-title">Twinfinite</h2>
</div>
<div class="mvp-nav-left-in">
<div id="mvp-nav-right-wrap" class="left">
<div class="mvp-nav-right-out">
<div class="mvp-nav-right-in">
<div id="mvp-nav-main" class="left">
<nav id="mvp-nav-menu">
<div class="menu-menu-container"><ul id="menu-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92"><a href="https://twinfinite.net/category/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-381971"><a href="https://twinfinite.net/category/guides/">Guides</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-93"><a href="https://twinfinite.net/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://twinfinite.net/category/reviews/">Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-106"><a href="https://twinfinite.net/category/xbox-one/">Xbox</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-95"><a href="https://twinfinite.net/category/pc/">PC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96"><a href="https://twinfinite.net/category/ps4/">PlayStation</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-250317"><a href="https://twinfinite.net/category/switch/">Nintendo</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181803"><a href="https://twinfinite.net/category/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-418729"><a href="https://twinfinite.net/category/quiz/">Quizzes</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-789520"><a href="#">About Us &#038; Policies</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-803504"><a href="https://twinfinite.net/about-us/">About Us &#038; Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-803503"><a href="https://twinfinite.net/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-789521"><a href="https://twinfinite.net/fact-checking-policy/">Fact-checking Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-789522"><a href="https://twinfinite.net/ownership-policy/">Ownership Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-789523"><a href="https://twinfinite.net/corrections-policy/">Corrections Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-789524"><a href="https://twinfinite.net/ethics-policy/">Ethics Policy</a></li>
</ul>
</li>
</ul></div> </nav>
</div>
</div>
<div id="mvp-nav-right" class="relative">
<div id="mvp-nav-soc" class="left relative">
<a href="https://www.facebook.com/2winfinite/" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook fa-2"></span></a>
<a href="https://twitter.com/Twinfinite" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a>
</div>
<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="mvp-nav-soc-bar">
<div class="mvp-main-out relative">
<div class="mvp-main-in">
<div id="mvp-nav-soc-cont" class="left relative">
<div id="mvp-nav-soc-title" class="left">
<h4>Who Died in the White Lotus Season 2 Finale? Answered</h4>
</div>
<div id="mvp-nav-soc-list" class="left">
<ul class="mvp-post-soc-list left relative">
<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/&amp;t=Who Died in the White Lotus Season 2 Finale? Answered', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="mvp-post-soc-fb">
<i class="fa fa-facebook-square fa-2" aria-hidden="true"></i><span class="mvp-post-soc-text">Share</span>
</li>
</a>
<a href="#" onclick="window.open('https://twitter.com/share?text=Who Died in the White Lotus Season 2 Finale? Answered -&amp;url=https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="mvp-post-soc-twit">
<i class="fa fa-twitter fa-2" aria-hidden="true"></i><span class="mvp-post-soc-text">Tweet</span>
</li>
</a>
<a href="whatsapp://send?text=Who Died in the White Lotus Season 2 Finale? Answered https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/">
<li class="mvp-post-soc-what">
<i class="fa fa-whatsapp fa-2" aria-hidden="true"></i>
</li>
</a>
<a href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/&amp;media=https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg?resize=1000%2C600&amp;description=Who Died in the White Lotus Season 2 Finale? Answered', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<li class="mvp-post-soc-pin">
<i class="fa fa-pinterest-p fa-2" aria-hidden="true"></i>
</li>
</a>
<a href="/cdn-cgi/l/email-protection#d2eda1a7b0b8b7b1a6ef85babdf296bbb7b6f2bbbcf2a6bab7f285babba6b7f29ebda6a7a1f281b7b3a1bdbcf2e0f294bbbcb3beb7edf293bca1a5b7a0b7b6f4b3bfa2e9909d968bef9bf2b4bda7bcb6f2a6babba1f2b3a0a6bbb1beb7f2bbbca6b7a0b7a1a6bbbcb5f2b3bcb6f2a6babda7b5baa6f2bdb4f2a1bab3a0bbbcb5f2bba6f2a5bba6baf2abbda7fcf291bab7b1b9f2bba6f2bda7a6e8f2baa6a6a2a1e8fdfda6a5bbbcb4bbbcbba6b7fcbcb7a6fde0e2e0e0fde3e0fda5babdffb6bbb7b6ffa6bab7ffa5babba6b7ffbebda6a7a1ffa1b7b3a1bdbcffb4bbbcb3beb7fd">
<li class="mvp-post-soc-email">
<i class="fa fa-envelope-o fa-2" aria-hidden="true"></i>
</li>
</a>
</ul>
</div>
</div>
</div>
</div>
</div>
</header>

<div id='div-gpt-ad-1663206141364-0'>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-1663206141364-0'); });
			</script>
</div>
<div id="mvp-main-wrap" class="left relative pageContent" data-role="page">
<div class="mvp-main-boxed-wrap">
<div class="mvp-main-out relative">
<div class="mvp-main-in">
<div id="photoS"></div>
<span class="hidden postId">878751</span>
<div id="mvp-post-area" class="post-878751 post type-post status-publish format-standard has-post-thumbnail hentry category-guides tag-guide tag-guides tag-hbo tag-the-white-lotus tag-tv-series tag-tv-show article_type-seo">
<div class="mvp-content-side-out relative">
<div class="mvp-content-side-in">
<div id="mvp-content-left-wrap" class="left relative">
<main id="gamurs-inf-scroll-main">
<style>
      div.gamurs-inf-scroll-post {
        overflow-y:auto !important;
        overflow-x:clip !important;
      }
    </style>
<div class="gamurs-inf-scroll-post post-878751" style="overflow-y:auto;overflow-x:clip" data-id="878751" data-title="Who Died in the White Lotus Season 2 Finale? Answered" data-url="https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/" data-categories='guides' data-tags='guide,guides,hbo,the-white-lotus,tv-series,tv-show'>
<article id="mvp-post-content-wrap" class="relative" itemscope itemtype="http://schema.org/NewsArticle">
<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<meta itemscope itemprop="url" content="https://twinfinite.net">
<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemscope itemprop="url" content="https://twinfinite.net/wp-content/uploads/2018/08/Twinfinite-Logo-New.png">
</div>
<meta itemprop="name" content="Twinfinite">
</div>
<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/" />
<div id="mvp-post-feat-img" class="relative this-one" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
<img width="1200" height="676" src="https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg" class="featuredImage skip-lazy wp-post-image" alt="the white lotus season 2" decoding="async" srcset="https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg?w=1200 1200w, https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg?w=600 600w, https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg?w=80 80w, https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg?w=160 160w, https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg?w=621 621w, https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg?w=350 350w, https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg?w=250 250w, https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg?w=150 150w" sizes="(max-width: 1200px) 100vw, 1200px" /> <meta itemprop="url" content="https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg?fit=1200%2C676">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="676">
</div>
<div id="mvp-post-content" class="relative">
<div class="mvp-post-content-out relative">
<div class="mvp-post-content-in">
<div id="mvp-post-content-mid" class="relative">
<span class="mvp-feat-caption">Image Source: HBO</span>
<header id="mvp-post-head" class="relative">
<a class="mvp-post-cat-link" href="https://twinfinite.net/category/guides/"><div class="mvp-post-cat"><span class="mvp-post-cat">Guides</span></div></a>
<h1 class="mvp-post-title entry-title" itemprop="headline">Who Died in the White Lotus Season 2 Finale? Answered</h1>
<span class="mvp-post-excerpt"><p>Who were the dead bodies in the season 2 finale of The White Lotus, explained.</p>
</span>
<div id="mvp-post-info-wrap" class="relative">
<div id="mvp-post-info-top" class="relative">
<div class="mvp-post-info-out relative">
<div class="mvp-post-info-in">
<div id="mvp-post-author" class="relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
<p>By<p>
<span class="author-name vcard fn author" itemprop="name">
<a href="https://twinfinite.net/author/rafaboladeras/" title="Posts by Rafa Boladeras" class="author url fn" rel="author">Rafa Boladeras</a> </span>
<span class="mvp-author-twit">
<a href="https://twitter.com/https://twitter.com/rafaboladeras" class="twitter-but" target="_blank">
<i class="fa fa-twitter fa-2"></i>
</a>
</span>
</div>
<div id="mvp-post-date" class="relative">
<span class="post-info-text">Published on</span> <span class="date published"><time class="date published" itemprop="datePublished" datetime="2022-12-12">December 12, 2022</time> <time><span class="date updated"></span></time></span>
<span style="display:none" class="vcard author"><span class="fn">Rafa Boladeras</span></span>
<meta itemprop="dateModified" content="2022-12-12" />
</div>
</div>
</div>
</div>
<p id="breadcrumbs"><span><span><a href="https://twinfinite.net/">Home</a> » <span><a href="https://twinfinite.net/category/guides/">Guides</a> » <span class="breadcrumb_last" aria-current="page">Who Died in the White Lotus Season 2 Finale? Answered</span></span></span></span></p> <div id="mvp-post-info-bot" class="right relative">
<ul class="mvp-post-soc-list relative">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/&amp;t=Who Died in the White Lotus Season 2 Finale? Answered', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="mvp-post-soc-fb">
<i class="fa fa-facebook-square fa-2" aria-hidden="true"></i><span class="mvp-post-soc-text">Share</span>
</li>
</a>
<a href="#" onclick="window.open('http://twitter.com/share?text=Who Died in the White Lotus Season 2 Finale? Answered -&amp;url=https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="mvp-post-soc-twit">
<i class="fa fa-twitter fa-2" aria-hidden="true"></i><span class="mvp-post-soc-text">Tweet</span>
</li>
</a>
<a onclick="sweetDreams()" class="nightTime"><span>Night Mode</span><label class="switch"><input id="sweetDreams" type="checkbox"><span class="slider round"></span></label></a>
</ul>
</div>
</div>
</header>
<section id="mvp-content-main" itemprop="articleBody" class="post-878751 post type-post status-publish format-standard has-post-thumbnail hentry category-guides tag-guide tag-guides tag-hbo tag-the-white-lotus tag-tv-series tag-tv-show article_type-seo">
<div class="primis-player"></div><p>Season 2 of The White Lotus had a new location in Sicily and a new set of characters to watch spend a week in the marvelous White Lotus hotel. As the first season, it also haunted its fans with the promise of some dead bodies from the start. Who are they? Here’s the answer to <strong>who died in The White Lotus season 2 finale</strong>.</p> <h2 id="h-everyone-that-dies-in-the-white-lotus-season-2-finale">Everyone That Dies in The White Lotus Season 2 Finale</h2> <p>5 people died in the White Lotus season 2 finale. All of them were on Quentin’s yacht when it happened.&nbsp;</p> <p>It all started when, after a worrying call from her assistant Portia, Tanya has a revelation: her husband Greg wants to kill her, so he’ll get all her money. Drug dealer Niccolò is going to do it with the help of Quentin and the rest of the guys on the yacht. What happened after that? Below are listed all the characters who died and how it happened.</p> <ul> <li><strong>Tanya (Jennifer Coolidge) &#8211; </strong>While getting over the yacht railing, she missteps and falls, hitting her head on a dinghy on the way down. Either the hit, the sea, or a combination of both kills her.&nbsp;</li> <li><strong>Quentin (Tom Hollander) &#8211; </strong>Shot with a gun by Tanya.</li> <li><strong>Hugo (Paolo Camilli) &#8211; &nbsp;</strong>Shot with a gun by Tanya.</li> <li><strong>Didier (Bruno Gouery) &#8211;&nbsp;</strong>Shot with a gun by Tanya.</li> <li><strong>Niccolò (Stefano Gianino) &#8211;&nbsp;</strong>Shot with a gun by Tanya.</li> </ul> <p>The dead body of Tanya is the person Daphne (Meghann Fahy) finds on the water in the scene that started and ended the White Lotus&#8217; second season.</p> <p>Now that you know&nbsp;<strong>who died in the White Lotus season 2 finale,&nbsp;</strong>you can look for more guides and news about White Lotus on Twinfinite. From&nbsp;<a href="https://twinfinite.net/2022/11/where-was-white-lotus-season-2-filmed-answered/">where was this season shot</a>, to&nbsp;<a href="https://twinfinite.net/2022/10/all-survivor-players-in-the-white-lotus-so-far/">who are the Survivor players that have appeared on the show</a>, and how many of our&nbsp;<a href="https://twinfinite.net/2022/12/5-questions-we-have-going-into-the-white-lotus-season-2-finale/">5 questions going into the finale</a>&nbsp;we got right.</p>

<div class="sideBarHeader pb0 mt1">Related Posts</div>
<ul>
<li>
<a href="https://twinfinite.net/2022/12/5-questions-we-have-going-into-the-white-lotus-season-2-finale/" rel="bookmark" title="Permanent Link to 5 Questions We Have Going Into the White Lotus Season 2 Finale">5 Questions We Have Going Into the White Lotus Season 2 Finale</a>
</li>
<li>
<a href="https://twinfinite.net/2022/11/what-will-sharpe-ethnicity-the-white-lotus-season-2/" rel="bookmark" title="Permanent Link to What is Will Sharpe’s Ethnicity in The White Lotus Season 2? ">What is Will Sharpe’s Ethnicity in The White Lotus Season 2? </a>
</li>
<li>
<a href="https://twinfinite.net/2022/11/who-died-white-lotus-season-1/" rel="bookmark" title="Permanent Link to Who Died in White Lotus Season 1?">Who Died in White Lotus Season 1?</a>
</li>
<li>
<a href="https://twinfinite.net/2022/11/where-was-white-lotus-season-2-filmed-answered/" rel="bookmark" title="Permanent Link to Where Was White Lotus Season 2 Filmed? Answered">Where Was White Lotus Season 2 Filmed? Answered</a>
</li>
<li>
<a href="https://twinfinite.net/2022/10/what-is-aubrey-plazas-ethnicity-in-the-white-lotus-answered/" rel="bookmark" title="Permanent Link to What Is Aubrey Plaza&#8217;s Ethnicity in The White Lotus? Answered">What Is Aubrey Plaza&#8217;s Ethnicity in The White Lotus? Answered</a>
</li>
</ul>
<div class="row1">
<div onclick="loadDisqusDynamic(this, 'twinfinite-878751', 'https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/','Who Died in the White Lotus Season 2 Finale? Answered')" class="dynamicDisqus relative mvp-com-click"> <span class="mvp-comment-but-text">Comments</span></div>
<div id="endOfPage0" class="endOfPage0 pageDivider pdivide" data-author='Rafa Boladeras' data-url='https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/' data-post="878751" style="float:left; display:inline-block !important; margin-top:0px;"></div>
<div id="disqus_thread"></div>
</div>
<div id="twitcher"></div>
</div>
<div class="mixerwidget"></div>

<script type="application/ld+json">{"@context": "http://schema.org","@type": "Article","mainEntityOfPage": "https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/ ","publisher": {"@type":"Organization","name": "Twinfinite","logo": {"@type": "ImageObject","url": "https://twinfinite.net/wp-content/uploads/2018/08/Twinfinite-Logo-New.png","height": "60","width": "250"}},"headline": "Who Died in the White Lotus Season 2 Finale? Answered","datePublished": "2022-12-12T14:40:57-05:00","dateModified": "2022-12-12T14:41:04-05:00 ","author": {"@type": "Person","name": "Rafa Boladeras"},"image": {"@type": "ImageObject","url": "https://twinfinite.net/wp-content/uploads/2022/10/white-lotus-s2-1.jpg?fit=1200%2C676","width": "1200","height": "676"}}
</script>
</section>
<div id="mvp-ad-rel-wrap">
<div id="mvp-ad-rel-top" class="relative">
<span class="mvp-ad-rel-but mvp-ad-rel-click">Continue Reading</span>
</div>
<div id="mvp-ad-rel-bot" class="relative">
<div class="mvp-ad-rel-out relative">
<div class="mvp-ad-rel-in">
</div>
</div>
</div>
</div>
<div class="mvp-post-tags">
<span class="mvp-post-tags-header">Related Topics:</span><span itemprop="keywords"><a href="https://twinfinite.net/tag/guide/" rel="tag">Guide</a>, <a href="https://twinfinite.net/tag/guides/" rel="tag">Guides</a>, <a href="https://twinfinite.net/tag/hbo/" rel="tag">HBO</a>, <a href="https://twinfinite.net/tag/the-white-lotus/" rel="tag">the white lotus</a>, <a href="https://twinfinite.net/tag/tv-series/" rel="tag">TV series</a>, <a href="https://twinfinite.net/tag/tv-show/" rel="tag">TV Show</a></span>
</div>
<div class="posts-nav-link">
</div>
<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<meta itemscope itemprop="url" content="https://twinfinite.net">
<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<img src="https://twinfinite.net/wp-content/uploads/2018/08/Twinfinite-Logo-New.png" />
<meta itemscope itemprop="url" content="https://twinfinite.net/wp-content/uploads/2018/08/Twinfinite-Logo-New.png">
</div>
<meta itemprop="name" content="Twinfinite">
</div>
</div>
</div>
<div class="pagedContent ajaxDupe" id="ajaxLoaded1"></div>

</div>
</article>
<script>
	window.gamursInfScrollPageViewsURLs = window.gamursInfScrollPageViewsURLs || [window.location.href];
	window.gamursInfScrollOnUrlChange = function(permalink) {
		window.gamursInfScrollPageViewsURLs = window.gamursInfScrollPageViewsURLs || [];
		if (!window.gamursInfScrollPageViewsURLs.includes(permalink)) {
			window.gamursInfScrollPageViewsURLs.push(permalink);
						try {
				window.snowplow('trackPageView');
			} catch (e) {
				console.log(e)
			}
			try {
				pSUPERFLY.virtualPage({
					sections: 'Guides',
					authors: 'Rafa Boladeras',
					path: location.pathname,
					title: "Who Died in the White Lotus Season 2 Finale? Answered"
				})
			} catch (e) {
				console.log(e)
			}
			try {
				gtag('config', 'UA-25895090-4', {
					page_path: window.location.href.split("/").slice(3).join("/"),
					custom_map: {
						dimension2: "Rafa Boladeras",
						dimension3: Array.from(document.querySelector(".initGal") ? document.querySelector(".initGal").classList : []).includes("kgal") ? "Gallery" : "Theia",
						dimension4: document.querySelectorAll(".gamurs-inf-scroll-post").length,
						dimension5: 'Guides',
						dimension6: window.publishedTimeFrame,
						dimension7: 'Entertainment (Q3)'
					}
				})
			} catch (e) {
				console.log(e)
			}
		}
	}
</script> </div>
</main>
<input id="hiddenNextPost" type="hidden" value="https://twinfinite.net/2022/12/who-died-the-white-lotus-season-finale/">
<input id="hiddenPreviousPost" type="hidden" value="https://twinfinite.net/2022/12/the-witcher-3-wild-hunt-guide-how-to-complete-the-elusive-thief-contract/">
</div>
</div>
<div id="mvp-side-wrap" class="relative">
<style>
            #mvp-side-wrap .units {
                position: sticky;
                top: 20px;
            }
            #nonsticky-sidebar {
                padding: 1rem 0;
            }
            #nonsticky-sidebar:after {
                content: " ";
                display: table;
                clear: both;
            }
        </style>
<div id="nonsticky-sidebar">
<div class="widget mvp_catlist_widget">
<div class="mvp-wide-widget-wrap left relative">
<div class="mvp-wide-widget-story left relative">
<a href="https://twinfinite.net/2022/12/my-hero-academia-film-netflix/" rel="bookmark">
<div class="mvp-wide-widget-img left relative">
<img width="400" height="240" src="https://twinfinite.net/wp-content/uploads/2022/12/My-Hero-Academia-Netflix.jpg?resize=400%2C240" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="My Hero Academia Netflix" decoding="async" loading="lazy" srcset="https://twinfinite.net/wp-content/uploads/2022/12/My-Hero-Academia-Netflix.jpg?w=1000 1000w, https://twinfinite.net/wp-content/uploads/2022/12/My-Hero-Academia-Netflix.jpg?w=400 400w, https://twinfinite.net/wp-content/uploads/2022/12/My-Hero-Academia-Netflix.jpg?zoom=2&amp;resize=400%2C240 800w, https://twinfinite.net/wp-content/uploads/2022/12/My-Hero-Academia-Netflix.jpg?zoom=3&amp;resize=400%2C240 1200w" sizes="(max-width: 400px) 100vw, 400px" /> </div>
</a>
<div class="mvp-wide-widget-text left relative">
<a href="https://twinfinite.net/2022/12/my-hero-academia-film-netflix/" rel="bookmark"><h2>Netflix Nabs My Hero Academia Live-Action Film</h2></a>
<div class="mvp-feat1-info">
<span class="mvp-blog-author">By <a href="https://twinfinite.net/author/giuseppen/" title="Posts by Giuseppe Nelva" rel="author">Giuseppe Nelva</a></span><span class="mvp-blog-date"><i class="fa fa-clock-o"></i><span class="mvp-blog-time">December 12, 2022</span></span>
</div>
</div>
</div>
<div class="mvp-wide-widget-story left relative">
<a href="https://twinfinite.net/2022/12/mrbeast-is-coming-to-fortnite-with-a-1-million-cash-prize/" rel="bookmark">
<div class="mvp-wide-widget-img left relative">
<img width="400" height="240" src="https://twinfinite.net/wp-content/uploads/2022/12/fortnite-mrbeast-1.jpg?resize=400%2C240" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="Fortnite" decoding="async" loading="lazy" srcset="https://twinfinite.net/wp-content/uploads/2022/12/fortnite-mrbeast-1.jpg?w=1000 1000w, https://twinfinite.net/wp-content/uploads/2022/12/fortnite-mrbeast-1.jpg?w=400 400w, https://twinfinite.net/wp-content/uploads/2022/12/fortnite-mrbeast-1.jpg?zoom=2&amp;resize=400%2C240 800w, https://twinfinite.net/wp-content/uploads/2022/12/fortnite-mrbeast-1.jpg?zoom=3&amp;resize=400%2C240 1200w" sizes="(max-width: 400px) 100vw, 400px" /> </div>
</a>
<div class="mvp-wide-widget-text left relative">
<a href="https://twinfinite.net/2022/12/mrbeast-is-coming-to-fortnite-with-a-1-million-cash-prize/" rel="bookmark"><h2>MrBeast Is Coming to Fortnite With a $1 Million Cash Prize</h2></a>
<div class="mvp-feat1-info">
<span class="mvp-blog-author">By <a href="https://twinfinite.net/author/tomm/" title="Posts by Tom Meyer" rel="author">Tom Meyer</a></span><span class="mvp-blog-date"><i class="fa fa-clock-o"></i><span class="mvp-blog-time">December 12, 2022</span></span>
</div>
</div>
</div>
<div class="mvp-wide-widget-story left relative">
<a href="https://twinfinite.net/2022/12/the-witcher-3-next-gen-version-adds-ray-tracing-implements-community-mods-more/" rel="bookmark">
<div class="mvp-wide-widget-img left relative">
<img width="400" height="240" src="https://twinfinite.net/wp-content/uploads/2022/12/The-Witcher-3-1.jpg?resize=400%2C240" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="The Witcher 3 Next-Gen Version Adds Ray Tracing, Implements Community Mods, &amp; More" decoding="async" loading="lazy" srcset="https://twinfinite.net/wp-content/uploads/2022/12/The-Witcher-3-1.jpg?w=1000 1000w, https://twinfinite.net/wp-content/uploads/2022/12/The-Witcher-3-1.jpg?w=400 400w, https://twinfinite.net/wp-content/uploads/2022/12/The-Witcher-3-1.jpg?zoom=2&amp;resize=400%2C240 800w, https://twinfinite.net/wp-content/uploads/2022/12/The-Witcher-3-1.jpg?zoom=3&amp;resize=400%2C240 1200w" sizes="(max-width: 400px) 100vw, 400px" /> </div>
</a>
<div class="mvp-wide-widget-text left relative">
<a href="https://twinfinite.net/2022/12/the-witcher-3-next-gen-version-adds-ray-tracing-implements-community-mods-more/" rel="bookmark"><h2>The Witcher 3 Next-Gen Version Adds Ray Tracing, Implements Community Mods, &#038; More</h2></a>
<div class="mvp-feat1-info">
<span class="mvp-blog-author">By <a href="https://twinfinite.net/author/cameronw/" title="Posts by Cameron Waldrop" rel="author">Cameron Waldrop</a></span><span class="mvp-blog-date"><i class="fa fa-clock-o"></i><span class="mvp-blog-time">December 12, 2022</span></span>
</div>
</div>
</div>
</div>
</div> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<footer id="mvp-foot-wrap" class="left relative">
<div id="mvp-foot-top-wrap" class="left relative">
<div class="mvp-main-out relative">
<div class="mvp-main-in">
<div class="mvp-foot-in-wrap left relative">
<div class="footer-links">
<div class="footer-col">
<label>Game Categories</label>
<div class="menu-game-categories-container"><ul id="menu-game-categories" class="menu"><li id="menu-item-447803" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447803"><a href="https://twinfinite.net/?s=best">Best Games</a></li>
<li id="menu-item-447805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447805"><a href="https://twinfinite.net/category/wiki/">Game Guide Wikis</a></li>
<li id="menu-item-447807" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447807"><a href="https://twinfinite.net/category/opinion/">Opinions</a></li>
</ul></div>
</div>
<div class="footer-col">
<label>Popular Games</label>
<div class="menu-popular-games-right-now-container"><ul id="menu-popular-games-right-now" class="menu"><li id="menu-item-447833" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447833"><a href="https://twinfinite.net/?s=cyberpunk">Cyberpunk 2077</a></li>
<li id="menu-item-447835" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447835"><a href="https://twinfinite.net/?s=Valhalla">Assassin&#8217;s Creed: Valhalla</a></li>
<li id="menu-item-447840" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447840"><a href="https://twinfinite.net/?s=miles+morales">Spider-Man: Miles Morales</a></li>
<li id="menu-item-447843" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447843"><a href="https://twinfinite.net/?s=watch+dogs">Watch Dogs: Legion</a></li>
</ul></div>
</div>
<div class="footer-col">
<label>All Time Best</label>
<div class="menu-all-time-best-container"><ul id="menu-all-time-best" class="menu"><li id="menu-item-447847" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447847"><a href="https://twinfinite.net/tag/destiny/">Destiny</a></li>
<li id="menu-item-447849" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447849"><a href="https://twinfinite.net/tag/red-dead-redemption-2/">Red Dead Redemption 2</a></li>
<li id="menu-item-447851" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447851"><a href="https://twinfinite.net/tag/Fortnite/">Fortnite</a></li>
<li id="menu-item-447855" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447855"><a href="https://twinfinite.net/tag/the-sims/">The Sims</a></li>
<li id="menu-item-447856" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447856"><a href="https://twinfinite.net/tag/dragon-ball-z/">Dragon Ball Z</a></li>
</ul></div> </div>
<div class="footer-col">
<label>Twinfinite</label>
<div class="menu-game-categories-container"><ul id="menu-game-categories-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447803"><a href="https://twinfinite.net/?s=best">Best Games</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447805"><a href="https://twinfinite.net/category/wiki/">Game Guide Wikis</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-447807"><a href="https://twinfinite.net/category/opinion/">Opinions</a></li>
</ul></div> </div>
</div>
<ul class="mvp-foot-soc-list left relative">
<li><a href="https://www.facebook.com/2winfinite/" target="_blank" class="fa fa-facebook-official fa-2"></a></li>
<li><a href="https://twitter.com/Twinfinite" target="_blank" class="fa fa-twitter fa-2"></a></li>
</ul>
</div>
</div>
</div>
</div>
<div id="mvp-foot-bot-wrap" class="left relative">
<div class="mvp-main-out relative">
<div class="mvp-main-in">
<div class="mvp-foot-in-wrap left relative">
<div id="mvp-foot-copy" class="left relative">
<p>Copyright © 2022 GAMURS Group</p>
<p>
<a href="/privacy-policy/">Privacy Policy</a>
</p>
</div>
</div>
</div>
</div>
</div>
</footer>
</div>
<div class="mvp-fly-top back-to-top">
<i class="fa fa-angle-up fa-3"></i>
<span class="mvp-fly-top-text">To Top</span>
</div>
<div class="mvp-fly-fade mvp-fly-but-click">
</div>


<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NWJQJXJ"
height="0" width="0" style="display:none;visibility:hidden" aria-hidden="true"></iframe></noscript>
<script type="text/javascript" src="https://twinfinite.net/wp-content/mu-plugins/jetpack-11.6/_inc/build/photon/photon.min.js?m=1670526945g"></script><script async="async" defer="defer" src='https://infinite-scroll-js-bundle.gamurs.workers.dev/twinfinite' id='gamurs-infinite-scroll-js'></script>
<script id='hurrytimer-js-extra'>
var hurrytimer_ajax_object = {"ajax_url":"https:\/\/twinfinite.net\/wp-admin\/admin-ajax.php","ajax_nonce":"6e299a6b5a","disable_actions":"","methods":{"COOKIE":1,"IP":2,"USER_SESSION":3},"actionsOptions":{"none":1,"hide":2,"redirect":3,"stockStatus":4,"hideAddToCartButton":5,"displayMessage":6,"expire_coupon":7},"restartOptions":{"none":1,"immediately":2,"afterReload":3,"after_duration":4},"COOKIEPATH":"\/","COOKIE_DOMAIN":"","redirect_no_back":"1","expire_coupon_message":""};
</script>
<script type="text/javascript" src="https://twinfinite.net/_static/??-eJyVjsEOgjAQRH/IshoNysH4LaSusIVua3ebhr8XEhI8GI3XyXszAyUaG1iRFeKYO2KBPqc0KXlM0IqgCjgBG8JAWHniyskO3jTt0eMMjGQH49vOaCF+EJPiIrpnxjR9Er/urZoNmfUeCv9dsIW/Di+02ERRZUZv/nqoz/tjUzeXk3sBYX5srA=="></script> <script src='https://stats.wp.com/e-202250.js' defer></script>
<script>
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'210961778',post:'878751',tz:'-5',srv:'twinfinite.net',hp:'vip',j:'1:11.6'} ]);
		_stq.push([ 'clickTrackerInit', '210961778', '878751' ]);
	</script><div id="extraScripts"></div>
<link id="photoswipe1" rel="stylesheet" type="text/css" href="https://cdnjs.cloudflare.com/ajax/libs/photoswipe/4.1.2/photoswipe.min.css">
<link id="photoswipe2" rel="stylesheet" type="text/css" href="https://cdnjs.cloudflare.com/ajax/libs/photoswipe/4.1.2/default-skin/default-skin.min.css">
<script id="photoswipe3" src="https://twinfinite.net/wp-content/themes/click-mag-twinfinite/js/photoswipe-ui-default.js?v=5"></script>
<script id="photoswipe4" src="https://cdnjs.cloudflare.com/ajax/libs/photoswipe/4.1.2/photoswipe-ui-default.min.js"></script>
<script type="text/javascript" src="https://twinfinite.net/wp-content/themes/click-mag-twinfinite/js/mainScripts.js?v=13"></script>
<script defer language="javascript" type="text/javascript">
function adsenseLoad(){
	/*
        var adsense = document.createElement('script');
        adsense.type = 'text/javascript'; 
	    adsense.async = true;
        adsense.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js';
        var ads = document.getElementsByTagName('script')[0];
        ads.parentNode.insertBefore(adsense, ads);	
	
   (adsbygoogle = window.adsbygoogle || []).push({
        google_ad_client: "ca-pub-4161179981920468",
        enable_page_level_ads: true
   });
   */
}
	
function reloadAds(index,iteration){
	
	window.dataLayer.push({'event': 'video-reload'});

	if(typeof index === "undefined"){
		index = 0;
	}
	
	if(typeof iteration === "undefined"){
		iteration = 1;
	}
	
}
	
</script>
<script type="text/javascript" src="https://s.skimresources.com/js/114526X1689487.skimlinks.js"></script>
</body>
</html>